strip the kernel version suffix from target directories, except for brcm-2.4 (the...
[openwrt-10.03/.git] / target / linux / rb532 / patches / 500-Nand.patch
diff --git a/target/linux/rb532/patches/500-Nand.patch b/target/linux/rb532/patches/500-Nand.patch
new file mode 100644 (file)
index 0000000..7e4cb65
--- /dev/null
@@ -0,0 +1,29 @@
+Index: linux-2.6.21.1/drivers/mtd/nand/Kconfig
+===================================================================
+--- linux-2.6.21.1.orig/drivers/mtd/nand/Kconfig       2007-04-27 23:49:26.000000000 +0200
++++ linux-2.6.21.1/drivers/mtd/nand/Kconfig    2007-06-07 01:31:30.927069952 +0200
+@@ -75,6 +75,12 @@
+       help
+         Support for NAND flash on Technologic Systems TS-7250 platform.
++config MTD_NAND_RB500
++      tristate "NAND Flash device on RB500 board"
++      depends on MTD_NAND
++      help
++        Support for NAND flash on RB500 platform.
++
+ config MTD_NAND_IDS
+       tristate
+Index: linux-2.6.21.1/drivers/mtd/nand/Makefile
+===================================================================
+--- linux-2.6.21.1.orig/drivers/mtd/nand/Makefile      2007-04-27 23:49:26.000000000 +0200
++++ linux-2.6.21.1/drivers/mtd/nand/Makefile   2007-06-07 01:31:30.927069952 +0200
+@@ -10,6 +10,7 @@
+ obj-$(CONFIG_MTD_NAND_SPIA)           += spia.o
+ obj-$(CONFIG_MTD_NAND_AMS_DELTA)      += ams-delta.o
+ obj-$(CONFIG_MTD_NAND_TOTO)           += toto.o
++obj-$(CONFIG_MTD_NAND_RB500)          += rbmipsnand.o
+ obj-$(CONFIG_MTD_NAND_AUTCPU12)               += autcpu12.o
+ obj-$(CONFIG_MTD_NAND_EDB7312)                += edb7312.o
+ obj-$(CONFIG_MTD_NAND_AU1550)         += au1550nd.o