[ramips] adds ethernet driver, esw needs to be moved to swconfig, driver is missing...
[openwrt-10.03/.git] / target / linux / ramips / patches-2.6.30 / 104-watchdog.patch
diff --git a/target/linux/ramips/patches-2.6.30/104-watchdog.patch b/target/linux/ramips/patches-2.6.30/104-watchdog.patch
new file mode 100644 (file)
index 0000000..793bea1
--- /dev/null
@@ -0,0 +1,30 @@
+Index: linux-2.6.30.5/drivers/watchdog/Kconfig
+===================================================================
+--- linux-2.6.30.5.orig/drivers/watchdog/Kconfig       2009-08-16 23:19:38.000000000 +0200
++++ linux-2.6.30.5/drivers/watchdog/Kconfig    2009-09-04 15:19:34.000000000 +0200
+@@ -764,6 +764,13 @@
+       help
+         Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
++config RAMIPS_WDT
++      tristate "Ralink Watchdog Timer"
++      depends on MIPS_RALINK
++      help
++              Hardware driver for the built-in watchdog timer on Ralink MIPS SoCs.
++
++
+ # PARISC Architecture
+ # POWERPC Architecture
+Index: linux-2.6.30.5/drivers/watchdog/Makefile
+===================================================================
+--- linux-2.6.30.5.orig/drivers/watchdog/Makefile      2009-08-16 23:19:38.000000000 +0200
++++ linux-2.6.30.5/drivers/watchdog/Makefile   2009-09-04 15:19:34.000000000 +0200
+@@ -105,6 +105,7 @@
+ obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
+ obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
+ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
++obj-$(CONFIG_RAMIPS_WDT) += ramipswdt.o
+ # PARISC Architecture