This patch adds a target for the IBM PowerXCell Accelerator Board.
[openwrt-10.03/.git] / target / linux / pxcab / image / Makefile
diff --git a/target/linux/pxcab/image/Makefile b/target/linux/pxcab/image/Makefile
new file mode 100644 (file)
index 0000000..ae551fa
--- /dev/null
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/Prepare
+       cp $(LINUX_DIR)/arch/powerpc/boot/zImage $(KDIR)/zImage
+endef
+
+define Image/BuildKernel
+       mkdir -p $(BIN_DIR)
+       cp $(KDIR)/zImage $(BIN_DIR)/openwrt-$(BOARD)-zImage
+       cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+endef
+
+$(eval $(call BuildImage))