[au1500] resync au1550 kernel configuration
[openwrt-10.03/.git] / target / linux / pxa / Makefile
index 3e0e6cd3b33d945db9c1b8cea3f7edd3e8741a07..da78ed7671328814256bddd7d826b8dd20b2f1cd 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,18 +8,17 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=pxa
-BOARDNAME:=PXA
+BOARDNAME:=Marvell/Intel PXA2xx
 FEATURES:=jffs2 broken
 
-LINUX_VERSION:=2.6.21.5
+LINUX_VERSION:=2.6.21.7
+
+include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
-       Stub for boards based on intel PXA
+       Build images for PAX2xx systems, eg. Gumstix.
 endef
 
-include $(INCLUDE_DIR)/kernel-build.mk
-
-# include the profiles
--include profiles/*.mk
+KERNELNAME:="uImage"
 
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))