madwifi: add sta mode idle reassoc fix (#4091)
[openwrt-10.03/.git] / target / linux / pxa / Makefile
index 3e0e6cd3b33d945db9c1b8cea3f7edd3e8741a07..952110b05de7f89a1198a239a466653880d487a0 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,18 +8,23 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=pxa
-BOARDNAME:=PXA
+BOARDNAME:=Marvell/Intel PXA2xx
 FEATURES:=jffs2 broken
 
-LINUX_VERSION:=2.6.21.5
+LINUX_VERSION:=2.6.21.7
+
+include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
-       Stub for boards based on intel PXA
+       Build images for PAX2xx systems, eg. Gumstix.
 endef
 
-include $(INCLUDE_DIR)/kernel-build.mk
+define Kernel/Configure
+       $(call Kernel/Configure/Default)
+       $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
+       $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
+endef
 
-# include the profiles
--include profiles/*.mk
+KERNELNAME:="uImage"
 
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))