* Rename the AMCC target to PPC44x
[openwrt-10.03/.git] / target / linux / ppc44x / patches / 120-uncompressed_uImage.patch
diff --git a/target/linux/ppc44x/patches/120-uncompressed_uImage.patch b/target/linux/ppc44x/patches/120-uncompressed_uImage.patch
new file mode 100644 (file)
index 0000000..b1f2707
--- /dev/null
@@ -0,0 +1,17 @@
+diff -Nur linux-2.6.21/arch/ppc/boot/images/Makefile linux-2.6.21-owrt/arch/ppc/boot/images/Makefile
+--- linux-2.6.21/arch/ppc/boot/images/Makefile 2007-04-27 23:49:26.000000000 +0200
++++ linux-2.6.21-owrt/arch/ppc/boot/images/Makefile    2007-05-28 17:44:11.000000000 +0200
+@@ -20,11 +20,11 @@
+ quiet_cmd_uimage = UIMAGE  $@
+       cmd_uimage = $(CONFIG_SHELL) $(MKIMAGE) -A ppc -O linux -T kernel \
+-               -C gzip -a 00000000 -e 00000000 -n 'Linux-$(KERNELRELEASE)' \
++               -C none -a 00000000 -e 00000000 -n 'Linux-$(KERNELRELEASE)' \
+                -d $< $@
+ targets += uImage
+-$(obj)/uImage: $(obj)/vmlinux.gz
++$(obj)/uImage: $(obj)/vmlinux.bin
+       $(Q)rm -f $@
+       $(call cmd,uimage)
+       @echo -n '  Image: $@ '