don't pass build cflags to fuse kernel module
[openwrt-10.03/.git] / target / linux / package / fuse / Makefile
index 9db6295980579ee594953796ea63a417c35a0899..950a9d20cb523814e09bf6f3d6f40cef42f7ee76 100644 (file)
@@ -1,6 +1,7 @@
 # $Id$
 
 include $(TOPDIR)/rules.mk
+include ../../rules.mk
 
 PKG_NAME:=fuse
 PKG_VERSION:=2.2.1
@@ -20,7 +21,7 @@ endif
 
 include $(TOPDIR)/package/rules.mk
 
-$(eval $(call PKG_template,KMOD_FUSE,kmod-fuse,$(LINUX_VERSION)+$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,KMOD_FUSE,kmod-fuse,$(LINUX_VERSION)$(BOARD)+$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH),kernel ($(LINUX_VERSION)-$(BOARD)-$(KERNEL_RELEASE))))
 
 $(PKG_BUILD_DIR)/.configured:
        (cd $(PKG_BUILD_DIR); \
@@ -31,7 +32,6 @@ $(PKG_BUILD_DIR)/.configured:
                touch include/config.h.in ; \
                touch configure ; \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
                ./configure \
                  --target=$(GNU_TARGET_NAME) \
                  --host=$(GNU_TARGET_NAME) \
@@ -55,8 +55,8 @@ $(PKG_BUILD_DIR)/.configured:
                  --enable-shared \
                  --enable-static \
                  --enable-kernel-module \
-                 --enable-lib \
-                 --enable-util \
+                 --disable-lib \
+                 --disable-util \
                  --disable-example \
                  --disable-auto-modprobe \
                  --with-kernel=$(KERNEL_DIR) \
@@ -66,6 +66,7 @@ $(PKG_BUILD_DIR)/.configured:
 $(PKG_BUILD_DIR)/.built:
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
+               ARCH="$(LINUX_KARCH)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                SUBDIRS="kernel" \
                all install