fix base-files-arch package
[openwrt-10.03/.git] / target / linux / package / Makefile
index d1fc25d13b085eff40e10b1f82f944e126338858..43fbd60f22faeddd7a2d14b0470a152fbf1b83e1 100644 (file)
@@ -2,10 +2,16 @@
 include $(TOPDIR)/rules.mk
 
 package-$(BR2_PACKAGE_KMOD_FUSE) += fuse
+package-$(BR2_PACKAGE_KMOD_MINI_FO) += mini_fo
 package-$(BR2_PACKAGE_KMOD_SHFS) += shfs
 package-$(BR2_PACKAGE_KMOD_OPENSWAN) += openswan
+package-y += openwrt
+
+ifeq ($(BOARD),brcm)
 ifeq ($(LINUX_VERSION),2.4.30)
 package-$(BR2_PACKAGE_KMOD_WLCOMPAT) += wlcompat
+wlcompat-compile: openwrt-compile
+endif
 endif
 
 all: compile install