toolchain: ARM: Fix option conflict with multiarch
[openwrt/.git] / target / linux / omap / Makefile
index 21a312a4b7b583b102c4d5d1431a1f63550daed2..3e5c921d618e0ea678da2b18155da15a76f1907f 100644 (file)
@@ -4,27 +4,28 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=omap
 BOARDNAME:=TI OMAP3/4/AM33xx
-FEATURES:=usb usbgadget ext4 targz fpu audio display nand ubifs
-CPU_TYPE:=cortex-a9
+FEATURES:=usb usbgadget ext4 targz fpu audio display nand squashfs
+CPU_TYPE:=cortex-a8
 CPU_SUBTYPE:=vfpv3
 
-KERNEL_PATCHVER:=3.18
+KERNEL_PATCHVER:=4.14
 
 MAINTAINER:=Alexander Couzens <lynxis@fe80.eu>
 
 KERNELNAME:=zImage dtbs
 
-include $(INCLUDE_DIR)/target.mk
-
-DEFAULT_PACKAGES += uboot-omap-am335x_evm uboot-omap-omap3_beagle uboot-omap-omap3_overo uboot-omap-omap4_panda
-
 define Target/Description
        TI OMAP boards
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += partx-utils mkf2fs e2fsprogs
+
 $(eval $(call BuildTarget))