backfire: ar71xx: add support for the WNDR3700v2 board (backport of r25118)
[openwrt-10.03/.git] / target / linux / octeon / Makefile
index 93f758554c8bd9a71ea91db006f4c96f27a89794..182ec1e881ced50b19edfc136f519b96b7bb836c 100644 (file)
@@ -9,14 +9,14 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=octeon
 BOARDNAME:=Cavium Networks Octeon
-FEATURES:=squashfs jffs2 pci
-CFLAGS:=-Os -pipe -funit-at-a-time
+FEATURES:=squashfs jffs2 pci usb
+CFLAGS:=-Os -pipe -mtune=octeon -funit-at-a-time
 
-LINUX_VERSION:=2.6.30.6
+LINUX_VERSION:=2.6.30.10
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += hostapd-mini
+DEFAULT_PACKAGES += wpad-mini
 
 define Target/Description
        Build firmware images for Cavium Networks Octeon-based boards.