upgrade & standardize kernel versions
[openwrt-10.03/.git] / target / linux / magicbox / Makefile
index e003330f053b9ba4e60fab6293d1203b81a4cc3f..c03093e00e316608de789600d5a5744c557fef67 100644 (file)
@@ -9,13 +9,11 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=magicbox
 BOARDNAME:=Magicbox
-FEATURES:=squashfs jffs2
+FEATURES:=squashfs pci
 
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=2.6.24.2
+LINUX_KARCH:=ppc
 
-include $(INCLUDE_DIR)/kernel-build.mk
+include $(INCLUDE_DIR)/target.mk
 
-# include the profiles
--include profiles/*.mk
-
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))