ser -> openser from wr
[openwrt-10.03/.git] / target / linux / image / squashfs.mk
index 63eba445a04cad2bf8d6ee8cd614601158ff4921..7fe972a45efcce0a887ff228b64cf35b24589c6c 100644 (file)
@@ -1,3 +1,9 @@
+endian := le
+
+ifeq ($(ARCH),mips)
+       endian := be
+endif
+
 squashfs-prepare:
        $(MAKE) -C squashfs prepare $(MAKE_TRACE)
 
@@ -10,7 +16,7 @@ squashfs-clean:
 
 $(KDIR)/root.squashfs: install-prepare
        @mkdir -p $(KDIR)/root/jffs
-       $(STAGING_DIR)/bin/mksquashfs-lzma $(KDIR)/root $@ -nopad -noappend -root-owned -le $(MAKE_TRACE)
+       $(STAGING_DIR)/bin/mksquashfs-lzma $(KDIR)/root $@ -nopad -noappend -root-owned -$(endian) $(MAKE_TRACE)
        
 ifeq ($(IB),)
 squashfs-install: compile-targets $(BOARD)-compile