[backfire] merge r23293
[openwrt-10.03/.git] / target / linux / ifxmips / Makefile
index 031ff11f19a7c8d36357b123699253b339a9f579..b82f78263f8f636f0c7ddd7dbed4d4f09602b686 100644 (file)
@@ -9,13 +9,15 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=ifxmips
 BOARDNAME:=Infineon Mips
-FEATURES:=squashfs jffs2
-SUBTARGETS:=generic nfs
-LINUX_VERSION:=2.6.26.8
-#LINUX_VERSION:=2.6.27.13
+FEATURES:=squashfs jffs2 atm
+
+LINUX_VERSION:=2.6.30.10
+
+CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES+=uboot-ifxmips hostapd-mini
+DEFAULT_PACKAGES+=uboot-lantiq
+#kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl ifxmips-dsl-api ifxmips-dsl-control ifx-tapidemo
 
 define Target/Description
        Build firmware images for Infineon Mips Controllers