[backfire] merge r23293
[openwrt-10.03/.git] / target / linux / ifxmips / Makefile
index 01f1840a192b8c16d677d1c037cfe4373e862537..b82f78263f8f636f0c7ddd7dbed4d4f09602b686 100644 (file)
@@ -11,21 +11,16 @@ BOARD:=ifxmips
 BOARDNAME:=Infineon Mips
 FEATURES:=squashfs jffs2 atm
 
-LINUX_VERSION:=2.6.30.8
+LINUX_VERSION:=2.6.30.10
 
-include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES+=uboot-ifxmips kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl kmod-ifxmips-atm
+CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES+=uboot-lantiq
+#kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl ifxmips-dsl-api ifxmips-dsl-control ifx-tapidemo
 
 define Target/Description
        Build firmware images for Infineon Mips Controllers
 endef
 
-ifeq ($(KERNEL_PATCHVER),2.6.28)
-  define Kernel/Prepare
-       $(call Kernel/Prepare/Default)
-       mv $(LINUX_DIR)/include/asm-mips/* $(LINUX_DIR)/arch/mips/include/asm/
-  endef
-endif
-
 $(eval $(call BuildTarget))