upgrade x86 to 2.6.31.6, resync patches
[openwrt-10.03/.git] / target / linux / generic-2.6 / patches-2.6.31 / 052-lzo_compressed_kernel_for_x86.patch
index bfefe8bfde7aa6e70d6318310db38171435bebec..ea7d2400ba05b91490b524b1566eac415cf36780 100644 (file)
@@ -1,5 +1,3 @@
-diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig
-index 72ace95..89f7771 100644
 --- a/arch/x86/Kconfig
 +++ b/arch/x86/Kconfig
 @@ -49,6 +49,7 @@ config X86
@@ -10,8 +8,6 @@ index 72ace95..89f7771 100644
        select HAVE_ARCH_KMEMCHECK
  
  config OUTPUT_FORMAT
-diff --git a/arch/x86/boot/compressed/Makefile b/arch/x86/boot/compressed/Makefile
-index f8ed065..0e835d0 100644
 --- a/arch/x86/boot/compressed/Makefile
 +++ b/arch/x86/boot/compressed/Makefile
 @@ -4,7 +4,7 @@
@@ -23,7 +19,7 @@ index f8ed065..0e835d0 100644
  
  KBUILD_CFLAGS := -m$(BITS) -D__KERNEL__ $(LINUX_INCLUDE) -O2
  KBUILD_CFLAGS += -fno-strict-aliasing -fPIC
-@@ -48,10 +48,13 @@ $(obj)/vmlinux.bin.bz2: $(vmlinux.bin.all-y) FORCE
+@@ -48,10 +48,13 @@ $(obj)/vmlinux.bin.bz2: $(vmlinux.bin.al
        $(call if_changed,bzip2)
  $(obj)/vmlinux.bin.lzma: $(vmlinux.bin.all-y) FORCE
        $(call if_changed,lzma)
@@ -37,8 +33,6 @@ index f8ed065..0e835d0 100644
  
  quiet_cmd_mkpiggy = MKPIGGY $@
        cmd_mkpiggy = $(obj)/mkpiggy $< > $@ || ( rm -f $@ ; false )
-diff --git a/arch/x86/boot/compressed/misc.c b/arch/x86/boot/compressed/misc.c
-index 842b2a3..3b22fe8 100644
 --- a/arch/x86/boot/compressed/misc.c
 +++ b/arch/x86/boot/compressed/misc.c
 @@ -162,6 +162,10 @@ static int lines, cols;