preliminary 2.6.30 support
[openwrt-10.03/.git] / target / linux / generic-2.6 / patches-2.6.30 / 402-ledtrig_netdev.patch
diff --git a/target/linux/generic-2.6/patches-2.6.30/402-ledtrig_netdev.patch b/target/linux/generic-2.6/patches-2.6.30/402-ledtrig_netdev.patch
new file mode 100644 (file)
index 0000000..8a8c974
--- /dev/null
@@ -0,0 +1,21 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -299,4 +299,11 @@ config LEDS_TRIGGER_MORSE
+       tristate "LED Morse Trigger"
+       depends on LEDS_TRIGGERS
++config LEDS_TRIGGER_NETDEV
++      tristate "LED Netdev Trigger"
++      depends on LEDS_TRIGGERS
++      help
++        This allows LEDs to be controlled by network device activity.
++        If unsure, say Y.
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -39,3 +39,4 @@ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += 
+ obj-$(CONFIG_LEDS_TRIGGER_GPIO)               += ledtrig-gpio.o
+ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
+ obj-$(CONFIG_LEDS_TRIGGER_MORSE)      += ledtrig-morse.o
++obj-$(CONFIG_LEDS_TRIGGER_NETDEV)      += ledtrig-netdev.o