[kernel] add a polled GPIO buttons input driver
[openwrt-10.03/.git] / target / linux / generic-2.6 / patches-2.6.24 / 410-gpio_buttons.patch
diff --git a/target/linux/generic-2.6/patches-2.6.24/410-gpio_buttons.patch b/target/linux/generic-2.6/patches-2.6.24/410-gpio_buttons.patch
new file mode 100644 (file)
index 0000000..0395715
--- /dev/null
@@ -0,0 +1,30 @@
+--- linux-2.6.24.2.orig/drivers/input/misc/Kconfig     2007-08-21 06:33:06.000000000 +0200
++++ linux-2.6.24.2/drivers/input/misc/Kconfig  2007-10-08 10:57:23.000000000 +0200
+@@ -178,4 +178,20 @@
+         Say Y here if you want to support the built-in real time clock
+         of the HP SDC controller.
++config INPUT_GPIO_BUTTONS
++      tristate "Polled GPIO buttons interface"
++      depends on GENERIC_GPIO
++      select INPUT_POLLDEV
++      help
++        This driver implements support for buttons connected
++        to GPIO pins of various CPUs (and some other chips).
++
++        Say Y here if your device has buttons connected
++        directly to such GPIO pins.  Your board-specific
++        setup logic must also provide a platform device,
++        with configuration data saying which GPIOs are used.
++
++        To compile this driver as a module, choose M here: the
++        module will be called gpio-buttons.
++
+ endif
+--- linux-2.6.24.2.orig/drivers/input/misc/Makefile    2007-08-21 06:33:06.000000000 +0200
++++ linux-2.6.24.2/drivers/input/misc/Makefile 2007-10-08 10:50:12.000000000 +0200
+@@ -18,3 +18,4 @@
+ obj-$(CONFIG_INPUT_YEALINK)           += yealink.o
+ obj-$(CONFIG_HP_SDC_RTC)              += hp_sdc_rtc.o
+ obj-$(CONFIG_INPUT_UINPUT)            += uinput.o
++obj-$(CONFIG_INPUT_GPIO_BUTTONS)      += gpio_buttons.o