generic 2.6.24 support
[openwrt-10.03/.git] / target / linux / generic-2.6 / patches-2.6.24 / 401-led_alix.patch
diff --git a/target/linux/generic-2.6/patches-2.6.24/401-led_alix.patch b/target/linux/generic-2.6/patches-2.6.24/401-led_alix.patch
new file mode 100644 (file)
index 0000000..cb00274
--- /dev/null
@@ -0,0 +1,27 @@
+diff -Nur linux-2.6.23.1.orig/drivers/leds/Kconfig linux-2.6.23.1/drivers/leds/Kconfig
+--- linux-2.6.23.1.orig/drivers/leds/Kconfig   2007-10-12 12:43:44.000000000 -0400
++++ linux-2.6.23.1/drivers/leds/Kconfig        2007-10-31 02:36:22.000000000 -0400
+@@ -81,6 +81,12 @@
+       help
+         This option enables support for the PCEngines WRAP programmable LEDs.
++config LEDS_ALIX
++      tristate "LED Support for the ALIX 2/3 boards"
++      depends on LEDS_CLASS
++      help
++        This option enables support for the three LEDs on the PCEngines ALIX 2/3 boards.
++
+ config LEDS_H1940
+       tristate "LED Support for iPAQ H1940 device"
+       depends LEDS_CLASS && ARCH_H1940
+diff -Nur linux-2.6.23.1.orig/drivers/leds/Makefile linux-2.6.23.1/drivers/leds/Makefile
+--- linux-2.6.23.1.orig/drivers/leds/Makefile  2007-10-12 12:43:44.000000000 -0400
++++ linux-2.6.23.1/drivers/leds/Makefile       2007-10-31 02:36:17.000000000 -0400
+@@ -14,6 +14,7 @@
+ obj-$(CONFIG_LEDS_AMS_DELTA)          += leds-ams-delta.o
+ obj-$(CONFIG_LEDS_NET48XX)            += leds-net48xx.o
+ obj-$(CONFIG_LEDS_WRAP)                       += leds-wrap.o
++obj-$(CONFIG_LEDS_ALIX)                       += leds-alix.o
+ obj-$(CONFIG_LEDS_H1940)              += leds-h1940.o
+ obj-$(CONFIG_LEDS_COBALT)             += leds-cobalt.o
+ obj-$(CONFIG_LEDS_GPIO)                       += leds-gpio.o