[etrax] add patches for 2.6.30, remove config-default
[openwrt-10.03/.git] / target / linux / etrax / patches-2.6.30 / 500-i2c_gvc.patch
diff --git a/target/linux/etrax/patches-2.6.30/500-i2c_gvc.patch b/target/linux/etrax/patches-2.6.30/500-i2c_gvc.patch
new file mode 100644 (file)
index 0000000..dc63165
--- /dev/null
@@ -0,0 +1,41 @@
+--- a/arch/cris/arch-v10/drivers/Kconfig
++++ b/arch/cris/arch-v10/drivers/Kconfig
+@@ -450,11 +450,18 @@ config ETRAX_I2C
+         i2c_arg = I2C_READARG(STA013_READ_ADDR, reg);
+         val = ioctl(fd, _IO(ETRAXI2C_IOCTYPE, I2C_READREG), i2c_arg);
++config ETRAX_I2C_GVC
++      bool "I2C GVC support"
++      depends on ETRAX_ARCH_V10 && !ETRAX_I2C
++      select ETRAX_I2C_USES_PB_NOT_PB_I2C
++      help
++        Enables an I2C driver with Geert Vancompernolle improvement.
++
+ # this is true for most products since PB-I2C seems to be somewhat
+ # flawed..
+ config ETRAX_I2C_USES_PB_NOT_PB_I2C
+       bool "I2C uses PB not PB-I2C"
+-      depends on ETRAX_I2C
++      depends on ETRAX_I2C || ETRAX_I2C_GVC
+       help
+         Select whether to use the special I2C mode in the PB I/O register or
+         not.  This option needs to be selected in order to use some drivers
+@@ -478,7 +485,7 @@ config ETRAX_I2C_CLK_PORT
+ config ETRAX_I2C_EEPROM
+       bool "I2C EEPROM (non-volatile RAM) support"
+-      depends on ETRAX_I2C
++      depends on ETRAX_I2C || ETRAX_I2C_GVC
+       help
+         Enables I2C EEPROM (non-volatile RAM) on PB0 and PB1 using the I2C
+         driver.  Select size option: Probed, 2k, 8k, 16k.
+--- a/arch/cris/arch-v10/drivers/Makefile
++++ b/arch/cris/arch-v10/drivers/Makefile
+@@ -4,6 +4,7 @@
+ obj-$(CONFIG_ETRAX_AXISFLASHMAP)      += axisflashmap.o
+ obj-$(CONFIG_ETRAX_I2C)                       += i2c.o
++obj-$(CONFIG_ETRAX_I2C_GVC)           += i2c_gvc.o
+ obj-$(CONFIG_ETRAX_I2C_EEPROM)                += eeprom.o
+ obj-$(CONFIG_ETRAX_GPIO)              += gpio.o
+ obj-$(CONFIG_ETRAX_DS1302)            += ds1302.o