Prevent the ioctl from handling even unsupported ioctls
[openwrt-10.03/.git] / target / linux / brcm63xx-2.6 / Makefile
index b9946c4e1516f946d86bc8c2daf9e1b65f8c0960..948ff59e4d42871e776bf934115967b1d74157a5 100644 (file)
@@ -9,7 +9,9 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM963xx
-FEATURES:=squashfs jffs2 broken usb
+FEATURES:=squashfs jffs2 broken usb atm
+
+LINUX_VERSION:=2.6.22.1
 
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers
@@ -18,22 +20,7 @@ endef
 
 include $(INCLUDE_DIR)/kernel-build.mk
 
-define Profile/Broadcom
-  NAME:=Broadcom WiFi (default)
-  PACKAGES:=kmod-net-bcm43xx
-endef
-$(eval $(call Profile,Broadcom))
-
-define Profile/Atheros
-  NAME:=Atheros WiFi
-  PACKAGES:=kmod-madwifi
-endef
-$(eval $(call Profile,Atheros))
-
-define Profile/Ralink
-  NAME:=Ralink WiFi
-  PACKAGES:=kmod-rt61
-endef
-$(eval $(call Profile,Ralink))
+# include the profiles
+-include profiles/*.mk
 
 $(eval $(call BuildKernel))