make target/linux/* directories self-contained, use the selected kernel version for...
[openwrt-10.03/.git] / target / linux / brcm63xx-2.6 / Makefile
index a48442a69f3fd8bd47c6d15cd263f2c6d6aeb19c..7e61c731bae9dc519fedef9b52f38bbdad92be5f 100644 (file)
@@ -1,18 +1,24 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 include $(TOPDIR)/rules.mk
 
-LINUX_VERSION:=2.6.8.1
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=9517ca999e822b898fbdc7e72796b1aa
-
-include ./config
-include $(INCLUDE_DIR)/kernel.mk
-include $(INCLUDE_DIR)/kernel-build.mk
+ARCH:=mips
+BOARD:=brcm63xx
+BOARDNAME:=Broadcom BCM963xx
+FEATURES:=pci usb atm squashfs jffs2
 
+define Target/Description
+       Build firmware images for Broadcom based xDSL/routers
+       (e.g. Inventel Livebox, Siemens SE515)
+endef
 
-$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
-       #[ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches $(MAKE_TRACE)
-       [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches $(MAKE_TRACE)
-       @$(CP) config $(LINUX_DIR)/.config
-       @$(CP) ./files/built-in.o $(LINUX_DIR)/bcmdrivers/broadcom/
-       touch $@
+LINUX_VERSION:=2.6.17
+LINUX_RELEASE:=1
+LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
 
+include $(INCLUDE_DIR)/kernel-build.mk
+$(eval $(call BuildKernel))