make target/linux/* directories self-contained, use the selected kernel version for...
[openwrt-10.03/.git] / target / linux / brcm63xx-2.6 / Makefile
index a27147491a514b74fea2957148fe1747d304fbb6..7e61c731bae9dc519fedef9b52f38bbdad92be5f 100644 (file)
@@ -6,18 +6,19 @@
 #
 include $(TOPDIR)/rules.mk
 
-LINUX_VERSION:=2.6.16.7
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=9682b2bd6e02f3087982d7c3f5ba824e
-
-include ./config
-include $(INCLUDE_DIR)/kernel.mk
-include $(INCLUDE_DIR)/kernel-build.mk
+ARCH:=mips
+BOARD:=brcm63xx
+BOARDNAME:=Broadcom BCM963xx
+FEATURES:=pci usb atm squashfs jffs2
 
+define Target/Description
+       Build firmware images for Broadcom based xDSL/routers
+       (e.g. Inventel Livebox, Siemens SE515)
+endef
 
-$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
-       #[ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches $(MAKE_TRACE)
-       [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches $(MAKE_TRACE)
-       @$(CP) config $(LINUX_DIR)/.config
-       touch $@
+LINUX_VERSION:=2.6.17
+LINUX_RELEASE:=1
+LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
 
+include $(INCLUDE_DIR)/kernel-build.mk
+$(eval $(call BuildKernel))