[brcm63xx] refresh 2.6.32 patches, fix livebox support (#6821)
[openwrt-10.03/.git] / target / linux / brcm63xx / patches-2.6.32 / 008-usb-ehci-support.patch
index a0894abcfa12fae87dde783ca2a76bcc242178ec..45584e486cdaaac6b5e6026636719408f1799a81 100644 (file)
@@ -13,8 +13,6 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
  create mode 100644 arch/mips/bcm63xx/dev-usb-ehci.c
  create mode 100644 arch/mips/include/asm/mach-bcm63xx/bcm63xx_dev_usb_ehci.h
 
-diff --git a/arch/mips/bcm63xx/Kconfig b/arch/mips/bcm63xx/Kconfig
-index 76fbbf7..4aa21e8 100644
 --- a/arch/mips/bcm63xx/Kconfig
 +++ b/arch/mips/bcm63xx/Kconfig
 @@ -26,6 +26,8 @@ config BCM63XX_CPU_6358
@@ -26,8 +24,6 @@ index 76fbbf7..4aa21e8 100644
  endmenu
  
  source "arch/mips/bcm63xx/boards/Kconfig"
-diff --git a/arch/mips/bcm63xx/Makefile b/arch/mips/bcm63xx/Makefile
-index be5d7ad..6e229c2 100644
 --- a/arch/mips/bcm63xx/Makefile
 +++ b/arch/mips/bcm63xx/Makefile
 @@ -1,6 +1,6 @@
@@ -38,8 +34,6 @@ index be5d7ad..6e229c2 100644
  obj-$(CONFIG_EARLY_PRINTK)    += early_printk.o
  
  obj-y         += boards/
-diff --git a/arch/mips/bcm63xx/boards/board_bcm963xx.c b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-index e2c0c36..b0d3db3 100644
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
 @@ -25,6 +25,7 @@
@@ -50,7 +44,7 @@ index e2c0c36..b0d3db3 100644
  #include <board_bcm963xx.h>
  
  #define PFX   "board_bcm963xx: "
-@@ -804,6 +805,9 @@ int __init board_register_devices(void)
+@@ -805,6 +806,9 @@ int __init board_register_devices(void)
            !board_get_mac_address(board.enet1.mac_addr))
                bcm63xx_enet_register(1, &board.enet1);
  
@@ -60,9 +54,6 @@ index e2c0c36..b0d3db3 100644
        if (board.has_ohci0)
                bcm63xx_ohci_register();
  
-diff --git a/arch/mips/bcm63xx/dev-usb-ehci.c b/arch/mips/bcm63xx/dev-usb-ehci.c
-new file mode 100644
-index 0000000..4bdd675
 --- /dev/null
 +++ b/arch/mips/bcm63xx/dev-usb-ehci.c
 @@ -0,0 +1,49 @@
@@ -115,9 +106,6 @@ index 0000000..4bdd675
 +      ehci_resources[1].start = bcm63xx_get_irq_number(IRQ_EHCI0);
 +      return platform_device_register(&bcm63xx_ehci_device);
 +}
-diff --git a/arch/mips/include/asm/mach-bcm63xx/bcm63xx_dev_usb_ehci.h b/arch/mips/include/asm/mach-bcm63xx/bcm63xx_dev_usb_ehci.h
-new file mode 100644
-index 0000000..17fb519
 --- /dev/null
 +++ b/arch/mips/include/asm/mach-bcm63xx/bcm63xx_dev_usb_ehci.h
 @@ -0,0 +1,6 @@
@@ -127,7 +115,3 @@ index 0000000..17fb519
 +int bcm63xx_ehci_register(void);
 +
 +#endif /* BCM63XX_DEV_USB_EHCI_H_ */
--- 
-1.6.3.3
-
-