[brcm63xx] refresh 2.6.32 patches, fix livebox support (#6821)
[openwrt-10.03/.git] / target / linux / brcm63xx / patches-2.6.32 / 007-usb-ohci-support.patch
index 76775c41b933277c2e9d9e99420dceafb4b607e8..90f3e9fb16b7644e1144fa5b5570f0e1593f9d45 100644 (file)
@@ -13,8 +13,6 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
  create mode 100644 arch/mips/bcm63xx/dev-usb-ohci.c
  create mode 100644 arch/mips/include/asm/mach-bcm63xx/bcm63xx_dev_usb_ohci.h
 
-diff --git a/arch/mips/bcm63xx/Kconfig b/arch/mips/bcm63xx/Kconfig
-index fb177d6..76fbbf7 100644
 --- a/arch/mips/bcm63xx/Kconfig
 +++ b/arch/mips/bcm63xx/Kconfig
 @@ -16,10 +16,16 @@ config BCM63XX_CPU_6345
@@ -34,8 +32,6 @@ index fb177d6..76fbbf7 100644
  endmenu
  
  source "arch/mips/bcm63xx/boards/Kconfig"
-diff --git a/arch/mips/bcm63xx/Makefile b/arch/mips/bcm63xx/Makefile
-index 00064b6..be5d7ad 100644
 --- a/arch/mips/bcm63xx/Makefile
 +++ b/arch/mips/bcm63xx/Makefile
 @@ -1,5 +1,6 @@
@@ -46,8 +42,6 @@ index 00064b6..be5d7ad 100644
  obj-$(CONFIG_EARLY_PRINTK)    += early_printk.o
  
  obj-y         += boards/
-diff --git a/arch/mips/bcm63xx/boards/board_bcm963xx.c b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-index ea17941..e2c0c36 100644
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
 @@ -24,6 +24,7 @@
@@ -58,7 +52,7 @@ index ea17941..e2c0c36 100644
  #include <board_bcm963xx.h>
  
  #define PFX   "board_bcm963xx: "
-@@ -803,6 +804,9 @@ int __init board_register_devices(void)
+@@ -804,6 +805,9 @@ int __init board_register_devices(void)
            !board_get_mac_address(board.enet1.mac_addr))
                bcm63xx_enet_register(1, &board.enet1);
  
@@ -68,9 +62,6 @@ index ea17941..e2c0c36 100644
        if (board.has_dsp)
                bcm63xx_dsp_register(&board.dsp);
  
-diff --git a/arch/mips/bcm63xx/dev-usb-ohci.c b/arch/mips/bcm63xx/dev-usb-ohci.c
-new file mode 100644
-index 0000000..f1fb442
 --- /dev/null
 +++ b/arch/mips/bcm63xx/dev-usb-ohci.c
 @@ -0,0 +1,49 @@
@@ -123,9 +114,6 @@ index 0000000..f1fb442
 +      ohci_resources[1].start = bcm63xx_get_irq_number(IRQ_OHCI0);
 +      return platform_device_register(&bcm63xx_ohci_device);
 +}
-diff --git a/arch/mips/include/asm/mach-bcm63xx/bcm63xx_dev_usb_ohci.h b/arch/mips/include/asm/mach-bcm63xx/bcm63xx_dev_usb_ohci.h
-new file mode 100644
-index 0000000..518a04d
 --- /dev/null
 +++ b/arch/mips/include/asm/mach-bcm63xx/bcm63xx_dev_usb_ohci.h
 @@ -0,0 +1,6 @@
@@ -135,7 +123,3 @@ index 0000000..518a04d
 +int bcm63xx_ohci_register(void);
 +
 +#endif /* BCM63XX_DEV_USB_OHCI_H_ */
--- 
-1.6.3.3
-
-