bcm963xx: fix load address / kernel entry
[openwrt-10.03/.git] / target / linux / brcm63xx / image / Makefile
index 16c57cae4fc4df3b870c94af6fb43f56916303df..227dbd7a5469f271574c116083752ec2354db053 100644 (file)
@@ -7,8 +7,8 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-LOADADDR = 0x8108c8f4          # RAM start + 16M 
-KERNEL_ENTRY = 0x80100000      # Default kernel entry in arch/mips/Makefile
+LOADADDR = 0x80010000          # RAM start + 16M 
+KERNEL_ENTRY = $(LOADADDR)     # Newer kernels add a jmp to the kernel_entry at the start of the binary
 RAMSIZE = 0x01000000           # 64MB
 
 LOADER_MAKEOPTS= \