broadcom47xx-2.6 was missing usb support, which was needed for wl500gp
[openwrt-10.03/.git] / target / linux / brcm47xx-2.6 / Makefile
index 46e76503fc1d95f8c1d3e5acce904b2f0d2661c9..70bcda8b6434ef7a545d094ca0a22072e8f17662 100644 (file)
@@ -8,19 +8,18 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=brcm47xx
-BOARDNAME:=Broadcom BCM947xx/953xx (new code)
-FEATURES:=squashfs broken
+BOARDNAME:=Broadcom BCM947xx/953xx
+FEATURES:=squashfs usb
 
 define Target/Description
        Build firmware images for Broadcom based routers
-       (e.g. Linksys WRT54G(S), Asus WL-500g, Motorola WR850G)
-
-       This one builds the generic .trx images, activate one of the
-       options below for creating device specific files for use
-       with TFTP client too.
+       (e.g. Netgear WGT634U)
 endef
 
 include $(INCLUDE_DIR)/kernel-build.mk
-# DEFAULT_PACKAGES += kmod-switch
+DEFAULT_PACKAGES += kmod-switch kmod-diag
+
+# include the profiles
+-include profiles/*.mk
 
 $(eval $(call BuildKernel))