patch for busybox httpd that adds an option for redirecting all requests to a specifi...
[openwrt-10.03/.git] / target / linux / brcm47xx-2.6 / Makefile
index ca7fd5d2d1cbdf54834693e997686598f1e895fc..5f89f7721cc8b9b11aeae6e691282fc02a116842 100644 (file)
@@ -8,15 +8,18 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=brcm47xx
-BOARDNAME:=Broadcom BCM947xx/953xx (new code)
-FEATURES:=squashfs broken
+BOARDNAME:=Broadcom BCM947xx/953xx
+FEATURES:=squashfs
 
 define Target/Description
        Build firmware images for Broadcom based routers
-       (e.g. Linksys WRT54G(S), Asus WL-500g, Motorola WR850G)
+       (e.g. Netgear WGT634U)
 endef
 
 include $(INCLUDE_DIR)/kernel-build.mk
-# DEFAULT_PACKAGES += kmod-switch
+DEFAULT_PACKAGES += kmod-switch kmod-diag
+
+# include the profiles
+-include profiles/*.mk
 
 $(eval $(call BuildKernel))