reorder variables
[openwrt/.git] / target / linux / brcm-2.6 / Makefile
index 599282803662065933165e0baf7d397f08b35107..960c29789a60c98d33c182d182bbf4d57df8a45a 100644 (file)
@@ -25,5 +25,18 @@ LINUX_RELEASE:=1
 LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
 
 include $(INCLUDE_DIR)/kernel-build.mk
+DEFAULT_PACKAGES += kmod-switch
+
+define Profile/Atheros
+  NAME:=Atheros WiFi (default)
+  PACKAGES:=kmod-madwifi
+endef
+$(eval $(call Profile,Atheros))
+
+define Profile/None
+  NAME:=No WiFi
+  PACKAGES:=
+endef
+$(eval $(call Profile,None))
 
 $(eval $(call BuildKernel))