revert [8415], seems to be causing problems for the kernel build
[openwrt-10.03/.git] / target / linux / brcm-2.4 / Makefile
index 2294a0546b08157f33527a6789c9e333f85679a6..3158d497afc4a0e6ad000f4d17bc49108c2199df 100644 (file)
@@ -9,77 +9,19 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=brcm
 BOARDNAME:=Broadcom BCM947xx/953xx
-FEATURES:=pci usb pcmcia squashfs jffs2
-DEFAULT_PACKAGES += kmod-switch nvram
+FEATURES:=squashfs
 
 define Target/Description
        Build firmware images for Broadcom based routers
        (e.g. Linksys WRT54G(S), Asus WL-500g, Motorola WR850G)
-
-       This one builds the generic .trx images, activate one of the
-       options below for creating device specific files for use
-       with TFTP client too.
 endef
 
-LINUX_VERSION:=2.4.32
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=38f4d0830e95a20f4bfed17622d5557c
+KERNEL:=2.4
 
 include $(INCLUDE_DIR)/kernel-build.mk
+DEFAULT_PACKAGES += kmod-switch kmod-diag nvram
 
-define Profile/Broadcom
-  NAME:=Generic, Broadcom WiFi (default)
-  PACKAGES:=kmod-brcm-wl
-endef
-$(eval $(call Profile,Broadcom))
-
-define Profile/BroadcomMimo
-  NAME:=Generic, Broadcom WiFi (MIMO)
-  PACKAGES:=kmod-brcm-wl-mimo
-endef
-$(eval $(call Profile,BroadcomMimo))
-
-define Profile/Atheros
-  NAME:=Generic, Atheros WiFi
-  PACKAGES:=kmod-madwifi
-endef
-$(eval $(call Profile,Atheros))
-
-define Profile/None
-  NAME:=Generic, No WiFi
-  PACKAGES:=
-endef
-$(eval $(call Profile,None))
-
-
-define Profile/WRT54G3G
-  NAME:=Linksys WRT54G3G
-  PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-pcmcia-core kmod-pcmcia-serial kmod-nozomi comgt
-endef
-$(eval $(call Profile,WRT54G3G))
-
-define Profile/WL500G
-  NAME:=ASUS WL-500g
-  PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-lp
-endef
-$(eval $(call Profile,WL500G))
-
-define Profile/WL500GD
-  NAME:=ASUS WL-500g Deluxe
-  PACKAGES:=kmod-usb-core kmod-usb-uhci kmod-usb2
-endef
-$(eval $(call Profile,WL500GD))
-
-define Profile/WL500GP
-  NAME:=ASUS WL-500g Premium
-  PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2
-endef
-$(eval $(call Profile,WL500GP))
-
-define Profile/WLHDD
-  NAME:=WL-HDD
-  PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-ide-core kmod-ide-pdc202xx
-endef
-$(eval $(call Profile,WLHDD))
+# include the profiles
+-include profiles/*.mk
 
 $(eval $(call BuildKernel))