add avr32 support to binutils 2.18
[openwrt-10.03/.git] / target / linux / avr32 / patches / 100-remove_build-id.patch
diff --git a/target/linux/avr32/patches/100-remove_build-id.patch b/target/linux/avr32/patches/100-remove_build-id.patch
new file mode 100644 (file)
index 0000000..1125d55
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/arch/avr32/boot/images/Makefile
++++ b/arch/avr32/boot/images/Makefile
+@@ -10,7 +10,7 @@ MKIMAGE              := $(srctree)/scripts/mkuboot.s
+ extra-y               := vmlinux.bin vmlinux.gz
+-OBJCOPYFLAGS_vmlinux.bin := -O binary
++OBJCOPYFLAGS_vmlinux.bin := -O binary -R .note.gnu.build-id
+ $(obj)/vmlinux.bin: vmlinux FORCE
+       $(call if_changed,objcopy)