[xburst] Export clock states through debugfs
[openwrt-10.03/.git] / target / linux / avr32 / image / Makefile
index 2cef2653bf1db6b0d3554e74219fc9b42346bb5a..692c325b5e0980abfaca1883b9ad2b61d2c53a90 100644 (file)
@@ -8,13 +8,15 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-define Build/Clean
+ifneq ($(CONFIG_AVR32_UBOOT),)
+  define Build/Clean
        $(MAKE) -C u-boot clean
-endef
+  endef
 
-define Build/Compile
+  define Build/Compile
        $(MAKE) -C u-boot compile
-endef
+  endef
+endif
 
 define Image/Prepare
        cp $(LINUX_DIR)/arch/avr32/boot/images/uImage $(KDIR)/uImage
@@ -23,7 +25,7 @@ endef
 define Image/BuildKernel
        cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
 
-       $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.lzma
+       $(STAGING_DIR_HOST)/bin/lzma e $(LINUX_DIR)/arch/avr32/boot/images/vmlinux.bin $(KDIR)/vmlinux.lzma
        mkimage -A avr32 -O linux -T kernel -a 0x10000000 -C lzma \
                -e 0x90000000 \
                -n 'OpenWrt Linux-$(LINUX_VERSION)' \