major target cleanup. it is now possible to have subtargets that can override many...
[openwrt-10.03/.git] / target / linux / avr32 / Makefile
index 4ab8534760795a4e39b6ecfcd97bce0f387f7f13..01d5838fe4d8adcb4c9023dd857bd225e5bb9112 100644 (file)
@@ -10,18 +10,15 @@ ARCH:=avr32
 BOARD:=avr32
 BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
-
 LINUX_VERSION:=2.6.22.4
 
+include $(INCLUDE_DIR)/target.mk
+
 define Target/Description
   Build firmware images for ATNGW100 board
 endef
 
-KERNEL:=2.6
-
-include $(INCLUDE_DIR)/kernel-build.mk
-
 #include the profiles
 -include profiles/*.mk
 
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))