build system cleanup/restructuring as described in http://lists.openwrt.org/pipermail...
[openwrt-10.03/.git] / target / linux / au1000-2.6 / Makefile
index 62d9acbdd16b745069db8210282919654808c8a7..bf6b5bd287a6960d64daa8e3774dd613448fa27a 100644 (file)
@@ -6,11 +6,20 @@
 #
 include $(TOPDIR)/rules.mk
 
-LINUX_VERSION:=2.6.17
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
+ARCH:=mipsel
+BOARD:=au1000
+BOARDNAME:=AMD Alchemy AU1x00
+FEATURES:=jffs2 usb pci
+
+LINUX_VERSION:=2.6.22.1
+
+define Target/Description
+       Build firmware for AMD Alchemy 1500 boards
+       (e.g. 4G-Systems Mesh/Access Cube ...)
+endef
 
 include $(INCLUDE_DIR)/kernel-build.mk
+DEFAULT_PACKAGES += yamonenv
 
 define Kernel/BuildImage
        $(call Kernel/BuildImage/Default)
@@ -18,5 +27,8 @@ define Kernel/BuildImage
        $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
 endef
 
+# include the profiles
+-include profiles/*.mk
+
 $(eval $(call BuildKernel))