build system cleanup/restructuring as described in http://lists.openwrt.org/pipermail...
[openwrt-10.03/.git] / target / linux / au1000-2.6 / Makefile
index 4daf61b370bd13f6d32e18f76ab8d34b2aa9f510..bf6b5bd287a6960d64daa8e3774dd613448fa27a 100644 (file)
@@ -9,18 +9,17 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=au1000
 BOARDNAME:=AMD Alchemy AU1x00
-FEATURES:=jffs2
+FEATURES:=jffs2 usb pci
+
+LINUX_VERSION:=2.6.22.1
 
 define Target/Description
        Build firmware for AMD Alchemy 1500 boards
        (e.g. 4G-Systems Mesh/Access Cube ...)
 endef
 
-LINUX_VERSION:=2.6.19
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=443c265b57e87eadc0c677c3acc37e20
-
 include $(INCLUDE_DIR)/kernel-build.mk
+DEFAULT_PACKAGES += yamonenv
 
 define Kernel/BuildImage
        $(call Kernel/BuildImage/Default)
@@ -28,23 +27,8 @@ define Kernel/BuildImage
        $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
 endef
 
-define Profile/Atheros
-  NAME:=Atheros WiFi (default)
-  PACKAGES:=kmod-madwifi
-endef
-$(eval $(call Profile,Atheros))
-
-define Profile/Intel
-  NAME:=Intel IPW2200 WiFi
-  PACKAGES:=kmod-net-ipw2200
-endef
-$(eval $(call Profile,Intel))
-
-define Profile/Broadcom
-  NAME:=Broadcom BCM43xx WiFi
-  PACKAGES:=kmod-net-bcm43xx
-endef
-$(eval $(call Profile,Broadcom))
+# include the profiles
+-include profiles/*.mk
 
 $(eval $(call BuildKernel))