hide rm -rf command in Makefile
[openwrt-10.03/.git] / target / linux / au1000-2.6 / Makefile
index 34d4ddaf93aad333d71a182c507e74844b32700e..5d2711cb30b1f447aff6ccc18f94db9b9ab70e24 100644 (file)
@@ -1,15 +1,18 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 include $(TOPDIR)/rules.mk
 
-LINUX_VERSION:=2.6.16.7
+LINUX_VERSION:=2.6.17
 LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=9682b2bd6e02f3087982d7c3f5ba824e
+LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
 
-include ../rules.mk
 include ./config
-
-include ../generic-$(KERNEL)/modules.mk
-include ../kernel.mk
-
+include $(INCLUDE_DIR)/kernel.mk
+include $(INCLUDE_DIR)/kernel-build.mk
 
 $(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
        [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches
@@ -20,6 +23,5 @@ $(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
 $(LINUX_BUILD_DIR)/zImage.flash.srec: $(LINUX_DIR)/vmlinux
        $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.flash.srec $(LINUX_DIR)/zImage.flash.srec
        $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
-       touch $@
 
 compile: $(LINUX_BUILD_DIR)/zImage.flash.srec