[kernel] update to 2.6.27.13
[openwrt-10.03/.git] / target / linux / au1000 / Makefile
index d7b9f739ab7f6fa2b953555f53456fa21d2f0b79..1f98a8df8ede6c21f60c42f53d14c6e47e41c19e 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,27 +8,23 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=au1000
-BOARDNAME:=AMD Alchemy AU1x00
+BOARDNAME:=RMI/AMD AU1x00
 FEATURES:=jffs2 usb pci
 
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=2.6.27.13
+
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += hostapd-mini yamonenv
 
 define Target/Description
        Build firmware for AMD Alchemy 1500 boards
        (e.g. 4G-Systems Mesh/Access Cube ...)
 endef
 
-include $(INCLUDE_DIR)/kernel-build.mk
-DEFAULT_PACKAGES += yamonenv
-
 define Kernel/BuildImage
        $(call Kernel/BuildImage/Default)
        $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.flash.srec $(LINUX_DIR)/zImage.flash.srec
        $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
 endef
 
-# include the profiles
--include profiles/*.mk
-
-$(eval $(call BuildKernel))
-
+$(eval $(call BuildTarget))