fix flash buswidth detection
[openwrt-10.03/.git] / target / linux / atheros-2.6 / Makefile
index f3f3ca6b4e8bcee7dc0b70e7a6f6438e40564dc9..1700dec8c6d48b4901e4805bbb249b953e6d82eb 100644 (file)
@@ -9,17 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=atheros
 BOARDNAME:=Atheros
-FEATURES:=jffs2
+FEATURES:=squashfs jffs2
 
 define Target/Description
-       Build firmware images for Atheros SoC boards (currently AR2315-AR2317)
+       Build firmware images for Atheros SoC boards
 endef
 
-LINUX_VERSION:=2.6.19
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=443c265b57e87eadc0c677c3acc37e20
-
 include $(INCLUDE_DIR)/kernel-build.mk
 DEFAULT_PACKAGES += kmod-madwifi
 
+# include the profiles
+-include profiles/*.mk
+
 $(eval $(call BuildKernel))