ar71xx: merge ar7240 fixes from trunk
[openwrt-10.03/.git] / target / linux / atheros / patches-2.6.32 / 210-reset_button.patch
index f76cde6ec3aba0868b39545756218307fa6ff423..3c91818146cf9001fcdc191915bd8612d08481f2 100644 (file)
@@ -1,20 +1,16 @@
-Index: linux-2.6.32.7/arch/mips/ar231x/Makefile
-===================================================================
---- linux-2.6.32.7.orig/arch/mips/ar231x/Makefile      2010-02-03 17:00:21.031428952 +0100
-+++ linux-2.6.32.7/arch/mips/ar231x/Makefile   2010-02-03 17:02:36.795429223 +0100
+--- a/arch/mips/ar231x/Makefile
++++ b/arch/mips/ar231x/Makefile
 @@ -8,7 +8,7 @@
  # Copyright (C) 2006-2009 Felix Fietkau <nbd@openwrt.org>
  #
  
 -obj-y += board.o prom.o devices.o
 +obj-y += board.o prom.o devices.o reset.o
- obj-$(CONFIG_ATHEROS_AR5312) += ar5312.o
- obj-$(CONFIG_ATHEROS_AR2315) += ar2315.o
- obj-$(CONFIG_ATHEROS_AR2315_PCI) += pci.o
-Index: linux-2.6.32.7/arch/mips/ar231x/reset.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.32.7/arch/mips/ar231x/reset.c    2010-02-03 17:02:36.795429223 +0100
+ obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
+--- /dev/null
++++ b/arch/mips/ar231x/reset.c
 @@ -0,0 +1,160 @@
 +#include <linux/init.h>
 +#include <linux/module.h>