[backfire] merge r27646
[openwrt-10.03/.git] / target / linux / atheros / patches-2.6.30 / 105-ar2315_pci.patch
index f5f0956e118fa6a4829cc216b5086bc2fafba37b..3f5e6b4528b0b051dfba35cf3089d5b7d8df1e09 100644 (file)
@@ -1,7 +1,7 @@
 --- a/arch/mips/ar231x/Makefile
 +++ b/arch/mips/ar231x/Makefile
-@@ -11,3 +11,4 @@
- obj-y += board.o prom.o devices.o
+@@ -14,3 +14,4 @@ obj-$(CONFIG_EARLY_PRINTK) += early_prin
  obj-$(CONFIG_ATHEROS_AR5312) += ar5312.o
  obj-$(CONFIG_ATHEROS_AR2315) += ar2315.o
 +obj-$(CONFIG_ATHEROS_AR2315_PCI) += pci.o
 +      default y
 --- a/arch/mips/ar231x/ar2315.c
 +++ b/arch/mips/ar231x/ar2315.c
-@@ -59,6 +59,27 @@ static inline void ar2315_gpio_irq(void)
+@@ -63,6 +63,27 @@ static inline void ar2315_gpio_irq(void)
                do_IRQ(AR531X_GPIO_IRQ_BASE + bit);
  }
  
  
  /*
   * Called when an interrupt is received, this function
-@@ -77,6 +98,10 @@ ar2315_irq_dispatch(void)
+@@ -81,6 +102,10 @@ ar2315_irq_dispatch(void)
                do_IRQ(AR2315_IRQ_WLAN0_INTRS);
        else if (pending & CAUSEF_IP4)
                do_IRQ(AR2315_IRQ_ENET0_INTRS);