port atheros to 2.6.24 (untested), but do not use the new kernel by default yet
[openwrt-10.03/.git] / target / linux / atheros / patches-2.6.23 / 130-ar2313_ethernet.patch
diff --git a/target/linux/atheros/patches-2.6.23/130-ar2313_ethernet.patch b/target/linux/atheros/patches-2.6.23/130-ar2313_ethernet.patch
new file mode 100644 (file)
index 0000000..721eba6
--- /dev/null
@@ -0,0 +1,29 @@
+Index: linux-2.6.23/drivers/net/Kconfig
+===================================================================
+--- linux-2.6.23.orig/drivers/net/Kconfig      2007-10-14 00:55:22.000000000 +0200
++++ linux-2.6.23/drivers/net/Kconfig   2007-10-14 00:56:32.000000000 +0200
+@@ -348,6 +348,12 @@
+         AX88796 driver, using platform bus to provide
+         chip detection and resources
++config AR2313
++      tristate "AR2313 Ethernet support"
++      depends on NET_ETHERNET && ATHEROS
++      help
++        Support for the AR231x/531x ethernet controller
++
+ config MACE
+       tristate "MACE (Power Mac ethernet) support"
+       depends on PPC_PMAC && PPC32
+Index: linux-2.6.23/drivers/net/Makefile
+===================================================================
+--- linux-2.6.23.orig/drivers/net/Makefile     2007-10-14 00:55:22.000000000 +0200
++++ linux-2.6.23/drivers/net/Makefile  2007-10-14 00:56:55.000000000 +0200
+@@ -182,6 +182,7 @@
+ obj-$(CONFIG_LGUEST_NET) += lguest_net.o
+ obj-$(CONFIG_MIPS_JAZZ_SONIC) += jazzsonic.o
+ obj-$(CONFIG_MIPS_AU1X00_ENET) += au1000_eth.o
++obj-$(CONFIG_AR2313) += ar2313/
+ obj-$(CONFIG_MIPS_SIM_NET) += mipsnet.o
+ obj-$(CONFIG_SGI_IOC3_ETH) += ioc3-eth.o
+ obj-$(CONFIG_DECLANCE) += declance.o