Added initial support for at91 plaform (HCG)
[openwrt-10.03/.git] / target / linux / at91-2.6 / Makefile
diff --git a/target/linux/at91-2.6/Makefile b/target/linux/at91-2.6/Makefile
new file mode 100644 (file)
index 0000000..982a911
--- /dev/null
@@ -0,0 +1,24 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=at91
+BOARDNAME:=AT91
+FEATURES:=squashfs
+
+define Target/Description
+  Build fimware images for Figment Design Labs VersaLink board.
+endef
+
+include $(INCLUDE_DIR)/kernel-build.mk
+
+#include the profiles
+-include profiles/*.mk
+
+KERNELNAME:="uImage"
+$(eval $(call BuildKernel))