atheros: USB support
[openwrt-10.03/.git] / target / linux / at91 / Makefile
index f8ca6f6be37d05b6021a28b6050b6d4d4e6011cb..87f156a43af066e0bb791cd4c54f942d51818901 100644 (file)
@@ -8,20 +8,17 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=at91
-BOARDNAME:=AT91
+BOARDNAME:=Atmel AT91
 FEATURES:=squashfs usb
 
-#LINUX_VERSION:=2.6.21.5
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=2.6.21.5
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:="uImage"
 
 define Target/Description
   Build fimware images for Figment Design Labs VersaLink board.
 endef
 
-include $(INCLUDE_DIR)/kernel-build.mk
-
-#include the profiles
--include profiles/*.mk
-
-KERNELNAME:="uImage"
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))