modernize backfire 10.03 so it can be operational again
[openwrt-10.03/.git] / target / linux / ar71xx / profiles / tp-link.mk
index 7efb1a3766fe643e237ef1a8ee3a73d3fa9b0172..493cf517ccde10e1564cd0d5302e5606e6b13640 100644 (file)
@@ -5,9 +5,20 @@
 # See /LICENSE for more information.
 #
 
+define Profile/TLMR3420V1
+       NAME:=TP-LINK TL-MR3420 v1
+       PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2
+endef
+
+define Profile/TLMR3420V1/Description
+       Package set optimized for the TP-LINK TL-MR3420 v1.
+endef
+
+$(eval $(call Profile,TLMR3420V1))
+
 define Profile/TLWR741NDV1
        NAME:=TP-LINK TL-WR741ND v1
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR741NDV1/Description
@@ -16,9 +27,21 @@ endef
 
 $(eval $(call Profile,TLWR741NDV1))
 
+
+define Profile/TLWR740NV1
+    NAME:=TP-LINK TL-WR740N v1
+    PACKAGES:=
+endef
+
+define Profile/TLWR740NV1/Description
+    Package set optimized for the TP-LINK TL-WR740N v1.
+endef
+
+$(eval $(call Profile,TLWR740NV1))
+
 define Profile/TLWR841NV15
        NAME:=TP-LINK TL-WR841N v1.5
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR841NV15/Description
@@ -29,7 +52,7 @@ $(eval $(call Profile,TLWR841NV15))
 
 define Profile/TLWR841NDV3
        NAME:=TP-LINK TL-WR841ND v3
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR841NDV3/Description
@@ -40,7 +63,7 @@ $(eval $(call Profile,TLWR841NDV3))
 
 define Profile/TLWR841NDV5
        NAME:=TP-LINK TL-WR841ND v5
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR841NDV5/Description
@@ -51,7 +74,7 @@ $(eval $(call Profile,TLWR841NDV5))
 
 define Profile/TLWR941NDV2
        NAME:=TP-LINK TL-WR941ND v2
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR941NDV2/Description
@@ -62,7 +85,7 @@ $(eval $(call Profile,TLWR941NDV2))
 
 define Profile/TLWR941NDV3
        NAME:=TP-LINK TL-WR941ND v3
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR941NDV3/Description
@@ -73,7 +96,7 @@ $(eval $(call Profile,TLWR941NDV3))
 
 define Profile/TLWR941NDV4
        NAME:=TP-LINK TL-WR941ND v4
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR941NDV4/Description
@@ -84,7 +107,7 @@ $(eval $(call Profile,TLWR941NDV4))
 
 define Profile/TLWR1043NDV1
        NAME:=TP-LINK TL-WR1043ND v1
-       PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2
+       PACKAGES:=kmod-usb-core kmod-usb2
 endef
 
 define Profile/TLWR1043NDV1/Description