ar71xx: experimental 2.6.32 support
[openwrt-10.03/.git] / target / linux / ar71xx / patches-2.6.32 / 005-ar71xx_mac_driver.patch
diff --git a/target/linux/ar71xx/patches-2.6.32/005-ar71xx_mac_driver.patch b/target/linux/ar71xx/patches-2.6.32/005-ar71xx_mac_driver.patch
new file mode 100644 (file)
index 0000000..72fc978
--- /dev/null
@@ -0,0 +1,21 @@
+--- a/drivers/net/Kconfig
++++ b/drivers/net/Kconfig
+@@ -2126,6 +2126,8 @@ config ACENIC_OMIT_TIGON_I
+         The safe and default value for this is N.
++source drivers/net/ag71xx/Kconfig
++
+ config DL2K
+       tristate "DL2000/TC902x-based Gigabit Ethernet support"
+       depends on PCI
+--- a/drivers/net/Makefile
++++ b/drivers/net/Makefile
+@@ -106,6 +106,7 @@ obj-$(CONFIG_STMMAC_ETH) += stmmac/
+ # end link order section
+ #
++obj-$(CONFIG_AG71XX) += ag71xx/
+ obj-$(CONFIG_SUNDANCE) += sundance.o
+ obj-$(CONFIG_HAMACHI) += hamachi.o
+ obj-$(CONFIG_NET) += Space.o loopback.o