ar71xx: add driver for the USB LED on the WNDR3700
[openwrt-10.03/.git] / target / linux / ar71xx / patches-2.6.30 / 205-wndr3700-usb-led-driver.patch
diff --git a/target/linux/ar71xx/patches-2.6.30/205-wndr3700-usb-led-driver.patch b/target/linux/ar71xx/patches-2.6.30/205-wndr3700-usb-led-driver.patch
new file mode 100644 (file)
index 0000000..53ece92
--- /dev/null
@@ -0,0 +1,26 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -227,6 +227,13 @@
+         This option enables support for BD2802GU RGB LED driver chips
+         accessed via the I2C bus.
++config LEDS_WNDR3700_USB
++      tristate "NETGEAR WNDR3700 USB LED driver"
++      depends on LEDS_CLASS && AR71XX_MACH_WNDR3700
++      help
++        This option enables support for the USB LED found on the
++        NETGEAR WNDR3700 board.
++
+ comment "LED Triggers"
+ config LEDS_TRIGGERS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -27,6 +27,7 @@
+ obj-$(CONFIG_LEDS_DA903X)             += leds-da903x.o
+ obj-$(CONFIG_LEDS_WM8350)             += leds-wm8350.o
+ obj-$(CONFIG_LEDS_PWM)                        += leds-pwm.o
++obj-${CONFIG_LEDS_WNDR3700_USB}               += leds-wndr3700-usb.o
+ # LED SPI Drivers
+ obj-$(CONFIG_LEDS_DAC124S085)         += leds-dac124s085.o