[ar71xx] add SPI driver for the Vitesse VSC7385 switch
[openwrt-10.03/.git] / target / linux / ar71xx / patches-2.6.30 / 202-spi_vsc7385_driver.patch
diff --git a/target/linux/ar71xx/patches-2.6.30/202-spi_vsc7385_driver.patch b/target/linux/ar71xx/patches-2.6.30/202-spi_vsc7385_driver.patch
new file mode 100644 (file)
index 0000000..b071d5d
--- /dev/null
@@ -0,0 +1,24 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -272,6 +272,11 @@ config SPI_TLE62X0
+         sysfs interface, with each line presented as a kind of GPIO
+         exposing both switch control and diagnostic feedback.
++config SPI_VSC7385
++      tristate "Vitesse VSC7385 ethernet switch driver"
++      help
++        SPI driver for the Vitesse VSC7385 ethernet switch.
++
+ #
+ # Add new SPI protocol masters in alphabetical order above this line
+ #
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -37,6 +37,7 @@ obj-$(CONFIG_SPI_SH_SCI)             += spi_sh_sci.
+ # SPI protocol drivers (device/link on bus)
+ obj-$(CONFIG_SPI_SPIDEV)      += spidev.o
++obj-$(CONFIG_SPI_VSC7385)     += spi_vsc7385.o
+ obj-$(CONFIG_SPI_TLE62X0)     += tle62x0.o
+ #     ... add above this line ...