[ar71xx] tl-wr941nd: change profile name to what new ar71xx image generation code...
[openwrt-10.03/.git] / target / linux / ar7 / patches-2.6.26 / 110-flash.patch
index 39bf83affc52bdc3c4481605a1856a53b2a12213..43e0c93fa94525a4045b907327da3de0ce49540c 100644 (file)
@@ -1,9 +1,8 @@
-diff -ruN linux-2.6.26.3.orig/drivers/mtd/Kconfig linux-2.6.26.3/drivers/mtd/Kconfig
---- linux-2.6.26.3.orig/drivers/mtd/Kconfig    2008-08-27 19:37:48.000000000 -0700
-+++ linux-2.6.26.3/drivers/mtd/Kconfig 2008-08-27 19:39:14.000000000 -0700
-@@ -174,6 +174,12 @@
-       ---help---
-         TI AR7 partitioning support
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -190,6 +190,12 @@ config MTD_MYLOADER_PARTS
+         You will still need the parsing functions to be called by the driver
+         for your particular device. It won't happen automatically.
  
 +config MTD_AR7_PARTS
 +      tristate "TI AR7 partitioning support"
@@ -14,27 +13,14 @@ diff -ruN linux-2.6.26.3.orig/drivers/mtd/Kconfig linux-2.6.26.3/drivers/mtd/Kco
  comment "User Modules And Translation Layers"
  
  config MTD_CHAR
-diff -ruN linux-2.6.26.3.orig/drivers/mtd/Makefile linux-2.6.26.3/drivers/mtd/Makefile
---- linux-2.6.26.3.orig/drivers/mtd/Makefile   2008-08-27 19:37:48.000000000 -0700
-+++ linux-2.6.26.3/drivers/mtd/Makefile        2008-08-27 19:39:14.000000000 -0700
-@@ -13,6 +13,7 @@
- obj-$(CONFIG_MTD_AFS_PARTS)   += afs.o
- obj-$(CONFIG_MTD_AR7_PARTS)   += ar7part.o
- obj-$(CONFIG_MTD_OF_PARTS)      += ofpart.o
-+obj-$(CONFIG_MTD_AR7_PARTS)   += ar7part.o
- # 'Users' - code which presents functionality to userspace.
- obj-$(CONFIG_MTD_CHAR)                += mtdchar.o
-diff -ruN linux-2.6.26.3.orig/drivers/mtd/maps/physmap.c linux-2.6.26.3/drivers/mtd/maps/physmap.c
---- linux-2.6.26.3.orig/drivers/mtd/maps/physmap.c     2008-08-27 19:37:48.000000000 -0700
-+++ linux-2.6.26.3/drivers/mtd/maps/physmap.c  2008-08-27 19:39:14.000000000 -0700
-@@ -87,7 +87,8 @@
+--- a/drivers/mtd/maps/physmap.c
++++ b/drivers/mtd/maps/physmap.c
+@@ -87,7 +87,7 @@ static int physmap_flash_remove(struct p
  
  static const char *rom_probe_types[] = { "cfi_probe", "jedec_probe", "map_rom", NULL };
  #ifdef CONFIG_MTD_PARTITIONS
 -static const char *part_probe_types[] = { "cmdlinepart", "RedBoot", NULL };
-+static const char *part_probe_types[] = {"cmdlinepart", "RedBoot",
-+                                      "ar7part", NULL };
++static const char *part_probe_types[] = { "cmdlinepart", "RedBoot", "ar7part", NULL };
  #endif
  
  static int physmap_flash_probe(struct platform_device *dev)