tools: build squashfs (v3) for ath79
[openwrt/.git] / target / linux / apm821xx / Makefile
index eb34a3b3dc4bf1333f622f18af5e4b41da4ea6d6..c3253322f2add7bdd407be5dda00f0a9f8fd7d7d 100644 (file)
@@ -11,9 +11,13 @@ CPU_TYPE:=464fp
 FEATURES:=fpu dt gpio
 MAINTAINER:=Chris Blake <chrisrblake93@gmail.com>, \
            Christian Lamparter <chunkeey@gmail.com>
-SUBTARGETS:=nand
+SUBTARGETS:=nand sata
 
-KERNEL_PATCHVER:=4.4
+KERNEL_PATCHVER:=4.14
+
+define Target/Description
+       Build images for AppliedMicro APM821xx based boards.
+endef
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -22,8 +26,4 @@ KERNELNAME:=uImage
 DEFAULT_PACKAGES += \
        kmod-leds-gpio kmod-i2c-core kmod-gpio-button-hotplug
 
-define Target/Description
-       Build images for AppliedMicro APM821xx based boards.
-endef
-
 $(eval $(call BuildTarget))