several cleanups for ifxmips. removes all code that has not been cleaned up properly
[openwrt-10.03/.git] / target / linux / amazon / patches / 100-board.patch
index 0293b04b57c9af7ce88e7aca21b2fc987b1ceeba..6c03e70b6ed4c5018aa433ca5eca3039484eb505 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.21.7/arch/mips/Kconfig
-===================================================================
---- linux-2.6.21.7.orig/arch/mips/Kconfig
-+++ linux-2.6.21.7/arch/mips/Kconfig
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
 @@ -159,6 +159,17 @@ config BASLER_EXCITE_PROTOTYPE
          note that a kernel built with this option selected will not be
          able to run on normal units.
@@ -28,10 +26,8 @@ Index: linux-2.6.21.7/arch/mips/Kconfig
  source "arch/mips/ddb5xxx/Kconfig"
  source "arch/mips/gt64120/ev64120/Kconfig"
  source "arch/mips/jazz/Kconfig"
-Index: linux-2.6.21.7/arch/mips/Makefile
-===================================================================
---- linux-2.6.21.7.orig/arch/mips/Makefile
-+++ linux-2.6.21.7/arch/mips/Makefile
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
 @@ -267,6 +267,13 @@ libs-$(CONFIG_MIPS_XXS1500)       += arch/mips
  load-$(CONFIG_MIPS_XXS1500)   += 0xffffffff80100000
  
@@ -46,16 +42,14 @@ Index: linux-2.6.21.7/arch/mips/Makefile
  # Cobalt Server
  #
  core-$(CONFIG_MIPS_COBALT)    += arch/mips/cobalt/
-Index: linux-2.6.21.7/include/asm-mips/bootinfo.h
-===================================================================
---- linux-2.6.21.7.orig/include/asm-mips/bootinfo.h
-+++ linux-2.6.21.7/include/asm-mips/bootinfo.h
+--- a/include/asm-mips/bootinfo.h
++++ b/include/asm-mips/bootinfo.h
 @@ -213,6 +213,12 @@
  #define MACH_GROUP_NEC_EMMA2RH 25     /* NEC EMMA2RH (was 23)         */
  #define  MACH_NEC_MARKEINS    0       /* NEC EMMA2RH Mark-eins        */
  
 +/*
-+ * Valid machtype for group ATHEROS
++ * Valid machtype for group Infineon
 + */
 +#define MACH_GROUP_INFINEON   27
 +#define MACH_INFINEON_AMAZON  0