prepare for the transition to linux 2.6.22 - make it possible to override the kernel...
[openwrt-10.03/.git] / target / linux / adm5120eb-2.6 / Makefile
index 7da6e5c3f4bfa3d877a02074c4108034c32984b2..b645d020cef756322e790409fc57c2a68e08dd18 100644 (file)
@@ -8,15 +8,16 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=adm5120eb
-BOARDNAME:=ADMtek 5120 (Big Endian)
-FEATURES:=squashfs broken
+BOARDNAME:=ADM5120 (Big Endian)
+FEATURES:=squashfs pci usb
 
 define Target/Description
-       Build firmware images for ADMTek ADM5120 based boards running in big-endian mode
+       Build firmware images for Infineon/ADMTek ADM5120 based boards running in big-endian mode
        (e.g : ZyXEL Prestige 335WT ...)
 endef
 
 include $(INCLUDE_DIR)/kernel-build.mk
+DEFAULT_PACKAGES += admswconfig
 
 # include the profiles
 -include profiles/*.mk